View Issue Details

IDProjectCategoryView StatusLast Update
0001159savapage-server[All Projects] Generalpublic2021-01-08 13:57
ReporterrijkrAssigned Torijkr 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.0 
Target Version1.3.0Fixed in Version1.3.0 
Summary0001159: Adapt to Java 11
DescriptionIST-1: Java 11 compiler reveals minor errors in junit tests of BigDecimal localize and parse methods.
SOLL-1: Do not anticipate on how Java applies currency symbol to BigDecimal values.
IST-2: Java 11 compiler shows error "package javax.xml.soap does not exist". This is because this package is deprecated since Java 9 and is removed in Java 11.
SOLL-2: Fix by adding Jakarta XML Web Services from Jakarta EE 8 as Maven dependency:
<dependency>
  <groupId>jakarta.xml.ws</groupId>
  <artifactId>jakarta.xml.ws-api</artifactId>
  <version>2.3.3</version>
</dependency>
<dependency>
  <groupId>com.sun.xml.ws</groupId>
  <artifactId>jaxws-rt</artifactId>
  <version>2.3.3</version>
  <scope>runtime</scope>
</dependency>
See https://stackoverflow.com/questions/54573998/java-11-package-javax-xml-soap-does-not-exist
TagsNo tags attached.

Relationships

related to 0001058 closedrijkr savapage-core Add Java 11 support 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-01-08 11:11 rijkr New Issue
2021-01-08 11:11 rijkr Status new => assigned
2021-01-08 11:11 rijkr Assigned To => rijkr
2021-01-08 12:29 rijkr Relationship added related to 0001058
2021-01-08 13:57 rijkr Status assigned => resolved
2021-01-08 13:57 rijkr Resolution open => fixed
2021-01-08 13:57 rijkr Fixed in Version => 1.3.0