View Issue Details

IDProjectCategoryView StatusLast Update
0001149savapage-server[All Projects] Refactoringpublic2020-11-09 19:32
ReporterrijkrAssigned Torijkr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.0 
Target Version1.3.0Fixed in Version1.3.0 
Summary0001149: Optimize JavaScript code
DescriptionIST-1: Several JavaScript object literal functions have a first parameter that refer to the object the function was invoked for. This parameter is obsolete, because the "this" object within the function can be used for that.
SOLL-1: Use "this" to refer to the object for which an object function is invoked.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-11-04 21:23 rijkr New Issue
2020-11-04 21:23 rijkr Status new => assigned
2020-11-04 21:23 rijkr Assigned To => rijkr
2020-11-09 19:32 rijkr Status assigned => resolved
2020-11-09 19:32 rijkr Resolution open => fixed
2020-11-09 19:32 rijkr Fixed in Version => 1.3.0